تنظیم آدرس آی‌پی روی سوییچ‌ها
چگونه سوییچ‌های کاتالیست سیسکو را پیکربندی کنیم؟
هنگامی‌که صحبت از پیکربندی سوییچ‌های کاتالیست سیسکو به میان می‌آید، تنوع زیاد است. برخی از آن‌ها با توان 10 مگابیت در ثانیه کار می‌کنند، در حالی که برخی دیگر توان عملیاتی 10 گیگابیت بر ثانیه و برخی دیگر ترکیبی از پورت‌های فیبرنوری و اترنت را برای ارائه بالاترین توان عملیاتی به خدمات می‌گیرند. سوئیچ‌های پیشرفته، مثل مدل 3850 از قابلیت‌های هوشمندی برای ارسال سریع داده‌ها استفاده می‌کنند. در این مطلب با نحوه پیکربندی سوییچ‌های کاتالیست سیسکو آشنا می‌شویم.

shabake-mag.jpg

مطلب پیشنهادی

معرفی انواع لایسنس سیسکو

فرآیند پیکربندی سوییچ‌ها با استفاده از رابط خط فرمان (CLI) انجام می‌شود. به‌طور معمول، کارشناسان شبکه به دو روش سوئیچ‌ها را پیکربندی می‌کنند. گروه اول؛ برخی تنظیمات اولیه را پیکربندی می‌کنند تا سوییچ بدون مشکل کار کند و برخی دیگر به سراغ تنظیمات پیشرفته‌ای می‌روند که پیکربندی شبکه‌های محلی مجازی (VLAN)، Inter-Switch Link (ISL) و ترانکینگ 802.1q را شامل می‌شود. از کارهای اولیه و اساسی که هنگام کار با سوییچ‌ها باید انجام دهید به موارد زیر باید اشاره کرد:

  • پیکربندی تنظیمات مدیریتی.
  • پیکربندی آدرس آی‌پی و ماسک زیر شبکه.
  • تنظیم گیت‌وی پیش‌فرض آی‌پی.
  • تنظیم ویژگی Port Security.
  • آزمایش و تایید شبکه.

مطلب پیشنهادی

راهنمای جامع آشنایی با انواع مختلف سوییچ‌های سیسکو

پیکربندی سوئیچ کاتالیست

قبل از این‌که به پیکربندی سوئیچ‌های کاتالیست (Catalyst) بپردازیم، ابتدا باید با نحوه بوت این سوئیچ‌ها آشنا شوید. یک سوئیچ عادی کاتالیست سیسکو در شکل یک نشان داده شده است.

اولین نکته‌ای که باید به آن اشاره کنیم این است که پورت کنسول برای سوئیچ‌های کاتالیست در پشت دستگاه قرار دارد. در سوئیچ‌هایی مثل  3560 که در شکل یک نشان داده شده، کنسول درست در مقابل دستگاه قرار دارد تا استفاده از آن ساده‌تر شود. سوییچ‌های هشت پورت 2960 نیز مشابه 3560 هستند. اگر عملیات POST با موفقیت به‌اتمام برسد، ال‌ئی‌دی روی دستگاه سبز می‌شود، اما عملیات POST با مشکل روبرو شود، چراغ کهربایی می‌شود که نشان می‌دهد، مشکل جدی وجود دارد. دکمه پایین در پنل سمت چپ دستگاه نشان می‌دهد کدام پورت‌ها از اترنت (PoE) استفاده می‌کنند. برای این منظور باید دکمه Mode را فشار دهید. همان‌گونه که اطلاع دارید، PoE یک ویژگی کاربردی است که اجازه می‌دهد، بدون نیاز به کابل‌کشی اضافی از یک کابل یکسان برای انتقال برق و داده استفاده کنید. شکل سه شبکه‌ای را نشان می‌دهد که سوییچ در آن پیکربندی شده و ما قصد تشریح عملکرد آن‌را داریم.

شما می‌توانید از هر سوئیچ لایه 2 در یک شبکه عادی استفاده کنید، اما هنگامی که صحبت از شبکه‌های پیچیده به میان می‌آید باید حداقل از یک روتر به اضافه یک سوئیچ لایه 3 مثل 3560 استفاده کنید. اگر در شبکه بیش از یک سوییچ دارید، باید آن‌ها را از طریق کراس‌اورر به یکدیگر متصل کنید. سوئیچ‌های 3560 توانایی تشخیص خودکار نوع اتصال را دارند، از این‌رو می‌توانید از کابل‌های مستقیم (Straight) نیز استفاده کنید، اما دقت کنید که همه سوئیچ‌ها قادر به تشخیص خودکار نوع کابل نیستند.

سوئیچ‌های مختلف نیازها و توانایی‌های متفاوتی دارند، بنابراین هنگام اتصال سوئیچ‌های مختلف به یکدیگر به این نکته دقت کنید.

وقتی برای اولین بار پورت‌های سوئیچ‌ها را به یکدیگر متصل می‌کنید، چراغ‌های لینک‌های روی سوییچ‌ها به رنگ کهربایی هستند و پس از گذشت چند ثانیه سبز رنگ می‌شوند که نشان می‌دهد، سوییچ مشکل سخت‌افزاری ندارد. اگر به یک درگاه سوئیچ وصل شدید و ال‌ئی‌دی پورت سوئیچ به‌طور متناوب سبز و کهربایی می‌شود، به این معنا است که پورت با خطایی روبرو شده است. وقتی این اتفاق می‌افتد، کارت شبکه میزبان یا کابل‌کشی و تنظیمات دوطرفه در پورت‌ها را بررسی کنید تا مطمئن شوید که با تنظیمات میزبان هماهنگ هستند.

مطلب پیشنهادی

سوئیچ شبکه چیست و چه کاری انجام می‌دهد؟
معرفی تجهیزات شبکه به زبان ساده

آیا نیازی به تنظیم آدرس آی‌پی روی سوییچ‌ها داریم؟

در حالت کلی، سوئیچ‌ها مجهز به پورت‌های فعال آماده به کار هستند. شما سوئیچ را از جعبه خارج کنید، کلاینت‌ها را به سوییچ و سوییچ را به روتر متصل می‌کند. در ادامه سوئیچ شروع به یادگیری مک آدرس‌‌ها می‌کند. با این‌حال، هنگامی که بحث مدیریت به میان می‌آید، سوییچ باید آدرس آی‌پی داشته باشد تا بتوان آن‌را به شکل کارآمدتری مدیریت کرد. پروتکل‌هایی مثل Telnet، SSH، SNMP و غیره، همگی به یک آدرس آی‌پی برای برقراری ارتباط با سوئیچی که درون یک شبکه محلی قرار دارد، نیاز دارند. به یاد داشته باشید، از آن‌جایی که همه پورت‌ها به‌طور پیش‌فرض فعال هستند، باید پورت‌های استفاده نشده را ببندید یا به دلایل امنیتی آن‌ها را به یک VLAN استفاده نشده اختصاص دهید.

با توجه به توضیحی که ارائه کردیم، این آدرس آی‌پی مدیریتی را باید به چه صورتی به سوییچ اختصاص دهیم؟ بهترین مکان، رابط مدیریتی VLAN است که یک رابط مسیریابی در سوئیچ‌های سیسکو است که VLAN 1 نام دارد. این رابط مدیریتی قابل تغییر است و سیسکو نیز توصیه می‌کند برای بهبود امنیت، این رابط مدیریتی را تغییر دهید. اکنون اجازه دهید، سوییچ‌های نشان داده شده در شکل سه را پیکربندی کنیم.

سوییچ S1

کار را با اتصال به هر سوئیچ و تنظیم عملکردهای مدیریتی آغاز می‌کنیم. همچنین، به هر سوئیچ یک آدرس آی‌پی اختصاص می‌دهیم، اما همان‌طور که اشاره شد، این‌کار با هدف بهبود عملکرد شبکه انجام نمی‌شود و تنها به دلیل توانایی مدیریت از راه دور سوییچ انجام می‌شود. اجازه دهید از یک طرح آی‌پی ساده مثل 192.168.10.161/28 استفاده کنیم. دستوراتی که برای پیکربندی سوییچ اجرا می‌کنیم در شکل چهار نشان داده شده است.

Switch>en

Switch#config t

Switch(config)#hostname S1

S1(config)#enable secret todd

S1(config)#int f0/15

S1(config-if)#description 1st connection to S3

S1(config-if)#int f0/16

S1(config-if)#description 2nd connection to S3

S1(config-if)#int f0/17

S1(config-if)#description 1st connection to S2

S1(config-if)#int f0/18

S1(config-if)#description 2nd connection to S2

S1(config-if)#int f0/8

S1(config-if)#desc Connection to IVR

S1(config-if)#line con 0

S1(config-line)#password console

S1(config-line)#login

S1(config-line)#line vty 0 15

S1(config-line)#password telnet

S1(config-line)#login

S1(config-line)#int vlan 1

S1(config-if)#ip address 192.168.10.17 255.255.255.240

S1(config-if)#no shut

S1(config-if)#exit

S1(config)#banner motd #this is my S1 switch#

S1(config)#exit

S1#copy run start

Destination filename [startup-config]? [enter]

Building configuration...

[OK]

S1#

اولین نکته‌ای که باید به آن اشاره کنیم این است که هیچ آدرس آی‌پی روی رابط‌های فیزیکی سوئیچ پیکربندی نشده است. از آن‌جایی که همه پورت‌های یک سوئیچ به‌طور پیش‌فرض فعال هستند، فرآیند پیکربندی ساده است. آدرس آی‌پی تحت یک رابط منطقی به نام دامنه مدیریت یا VLAN پیکربندی شده است. شما می‌توانید از VLAN 1 پیش‌فرض برای مدیریت یک شبکه سوئیچ شده استفاده کنید، به همان صورتی که این‌کار را انجام دادیم، هرچند می‌توانید از VLAN دیگری برای مدیریت استفاده کنید.

به یاد داشته باشید، هیچ آدرس آی‌پی در رابط‌های سوئیچ فیزیکی، هیچ پروتکل‌های مسیریابی، و غیره وجود ندارد، زیرا روی سوئیچینگ لایه 2 و نه مسیریابی متمرکز هستیم. همچنین توجه داشته باشید که در سوئیچ‌های سیسکو درگاه AUX وجود ندارد.

سوییچ S2

پیکربندی سوییچ S2 به شرح زیر است:

Switch#config t

Switch(config)#hostname S2

S2(config)#enable secret todd

S2(config)#int f0/1

S2(config-if)#desc 1st connection to S1

S2(config-if)#int f0/2

S2(config-if)#desc 2nd connection to s1

S2(config-if)#int f0/5

S2(config-if)#desc 1st connection to S3

S2(config-if)#int f0/6

S2(config-if)#desc 2nd connection to s3

S2(config-if)#line con 0

S2(config-line)#password console

S2(config-line)#login

S2(config-line)#line vty 0 15

S2(config-line)#password telnet

S2(config-line)#login

S2(config-line)#int vlan 1

S2(config-if)#ip address 192.168.10.18 255.255.255.240

S2(config)#exit

S2#copy run start

Destination filename [startup-config]?[enter]

Building configuration...

[OK]

S2#

اکنون باید بتوانیم به سوییچ S1 و S2 پینگ کنیم

S2#ping 192.168.10.17

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.10.17, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

S2#

خوب-حالا چرا من به جای پنج پینگ فقط چهار پینگ گرفتم؟ اولین مرتبه [.] تایم اوت است، اما علامت تعجب [!] به معنای موفقیت‌آمیز بودن عملیات است. در مجموع باید بگوییم که اولین پینگ به دلیل زمانی که ARP برای تبدیل آدرس IP به مک آدرس سخت‌افزاری مربوطه صرف می‌کند، کار نکرده است.

سوییچ S3

پیکربندی سوییچ سوم نیز به شرح زیر است:

Switch>en

Switch#config t

SW-3(config)#hostname S3

S3(config)#enable secret todd

S3(config)#int f0/1

S3(config-if)#desc 1st connection to S1

S3(config-if)#int f0/2

S3(config-if)#desc 2nd connection to S1

S3(config-if)#int f0/5

S3(config-if)#desc 1st connection to S2

S3(config-if)#int f0/6

S3(config-if)#desc 2nd connection to S2

S3(config-if)#line con 0

S3(config-line)#password console

S3(config-line)#login

S3(config-line)#line vty 0 15

S3(config-line)#password telnet

S3(config-line)#login

S3(config-line)#int vlan 1

S3(config-if)#ip address 192.168.10.19 255.255.255.240

S3(config-if)#no shut

S3(config-if)#banner motd #This is the S3 switch#

S3(config)#exit

S3#copy run start

Destination filename [startup-config]?[enter]

Building configuration...

[OK]

S3#

اکنون اجازه دهید از طریق سوییچ S3 به سوییچ‌های S1 و S2 پینگ کنیم. در این حالت خروجی‌های زیر را مشاهده خواهیم کرد:

S3#ping 192.168.10.17

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.10.17, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms

S3#ping 192.168.10.18

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.10.18, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms

S3#sh ip arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.10.17 0 001c.575e.c8c0 ARPA Vlan1

Internet 192.168.10.18 0 b414.89d9.18c0 ARPA Vlan1

Internet 192.168.10.19 - ecc8.8202.82c0 ARPA Vlan1

S3#

در خروجی دستور show ip arp، خط تیره (-) در ستون دقیقه به این معنی است که رابط دسگاه فیزیکی است.

اکنون، قبل از اینکه به بررسی تنظیمات سوئیچ بپردازیم، یک دستور دیگر وجود دارد که باید در مورد آن بدانید. این دستور ip default-gateway است. اگر می‌خواهید سوئیچ‌های خود را از خارج از شبکه محلی خود مدیریت کنید، باید یک دروازه پیش‌فرض روی سوئیچ‌ها درست مانند یک میزبان تنظیم کنید، و این کار را از پیکربندی سراسری انجام دهید. در اینجا مثالی وجود دارد که در آن روتر خود را با یک آدرس IP با استفاده از آخرین آدرس IP در محدوده زیر شبکه خود معرفی می‌‌کنیم:

S3#config t

S3(config)#ip default-gateway 192.168.10.30

همان‌گونه که مشاهده کردید، پیکربندی سه سوئیچ بر مبنای الگویی که در شکل بالا انجام دادیم به اتمام رسیده است. شما می‌توانید در صورت لزوم کارهای پیشرفته‌تری مثل تامین امنیت پورت را انجام دهید تا به شکل کارآمدتری از سوییچ‌ها محافظت کنید.

ماهنامه شبکه را از کجا تهیه کنیم؟
ماهنامه شبکه را می‌توانید از کتابخانه‌های عمومی سراسر کشور و نیز از دکه‌های روزنامه‌فروشی تهیه نمائید.

ثبت اشتراک نسخه کاغذی ماهنامه شبکه     
ثبت اشتراک نسخه آنلاین

 

کتاب الکترونیک +Network راهنمای شبکه‌ها

  • برای دانلود تنها کتاب کامل ترجمه فارسی +Network  اینجا  کلیک کنید.

کتاب الکترونیک دوره مقدماتی آموزش پایتون

  • اگر قصد یادگیری برنامه‌نویسی را دارید ولی هیچ پیش‌زمینه‌ای ندارید اینجا کلیک کنید.

ایسوس

نظر شما چیست؟